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K.S.R.M. COLLEGE OF ENGINEERING
(UGC - AUTONOMOUS)
Kadapa, Andhra Pradesh, India - 516003

Approved by AICTE, New Delhi & Affiliated to JNTUA, Ananthapuramu.
An ISO 14001:2004 & 9001: 2015 Certified Institution

Lr./KSRMCE/ (Department of CSE)/2018-19

Date: 01/03/2019

To

The Principal

KSRM College of Engineering
Kadapa, AP.

Sub: KSRMCE - (Department of €51) — Permission to conduct certification course on .Net Technology -
Requested — reg.
Respected Sir,

With reference to the cited, the Department of CSE is planning to conduct certificate course on “.Net
Technology” for B.Tech students from 04/03/2019 to 23/03/2019. So I request you to grant permission to
conduct the certificate course. This is submitted for your kind perusal.

Thanking you sir,

:P.r-— Yours Faithfully,
GJ"»’A ok oy } \A/
@ e WAL oordinator,
‘ a“‘”/ S. Khaja Khizar

Assistant Professor,
CSE Dept.,
Cc: 9 \
To The Director for Information B

To All Deans/HODs ) -



K.S.R.M. COLLEGE OF ENGINEERING

(UGC - AUTONOMOUS)
Kadapa, Andhra Pradesh, India - 516003

Approved by AICTE, New Delhi & Affiliated to JNTUA, Ananthapuramu.
An ISO 14001:2004 & 9001: 2015 Certified Institution

Dated: 02/03/2019

Circular

All the B.Tec students are here by informed that department of Computer Science & Engineering is
going to organize certification course on “.Net Technology” from 04/03/2019 to 23/03/2019. Interested
students do register their names with the below mentioned coordinator on or before 03/03/2019, 5 PM.

For any queries contact,

Coordinator
Sri. S. Khaja Khizar ,
Assistant Professor,

CSE Dept.,
é/\”\a\,\)
HoD
Dr. M. Sreenivasulu,
M. E, Ph. D,
. Professer & HOD CSE
K.S.R.M. College of Engineering
KADAPA-516003
Cc to:

The Management /Director / All Deans / All HODS/Staff / Students for information

The IQAC Cell for Documentation
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Date: 02/03/2019

Department of Computer Science & Engineering
Certificate Course on .Net Technology (04/03/2019 to 23/03/2019)
Registered Student List

S.No. | Roll Number | Name Of The Student Year & Branch Signature

Coordinator HoD
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Date: 02/03/2019

Department of Computer Science & Engineering

Certificate Course on .Net Technology (04/03/2019 to 23/03/2019)

Registered Student List

.S.NO. Roll Number | Name Of The Student Year & Branch Signature
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HoD
Dr. M. Sreenivasuly,

M- E . Bh. D
Professer & HOD csag

K.SRM. College of Engineering

KADAPA-515003




K.S.R.M. College of Engineering (Autonomous), Kadapa.
Department of CSE
Certificate Course on
.Net Technology
Syllabus

Overview: The course is designed to provide complete knowledge on .net technology and to
enhance the programming skills of the students by giving practical assignments to be done in
labs.

Course Objectives: .Net is a framework that provides programming guidelines that can be used
to develop a wide range of applications from web to mobile to windows-based application.

Course Outcomes: At the end of the course participants will be able to

1. Understand the basics of VB.NET&ASP.NET
2. Understand the concept of error and exception handling.
3. Understand the OOPS Concepts.

Module 1: Introduction to the .NET initiative and the .NET platform

Module 2: Code Management
Module 3: Object oriented programming concepts and Error and Exception handling

Module 4: Using controls and components for designing application.
Module 5: Design web application using ASP.net

Textbook:

C# 6.0 and the NET 4.6 Framework by Andrew Troelsen and Philip Japikse.
Programming Entity Framework by Julia Lerman.

Pro ASP.Net MVC 5 (Expert's Voice in ASP.Net) by Adam Freeman.
Dependency Injection in .NET by Mark Seemann.

C# in Depth by Jon Skeet.



K.S.R.M. COLLEGE OF ENGINEERING

(UGC - AUTONOMOUS)
Kadapa, Andhra Pradesh, India - 516003

Approved by AICTE, New Delhi & Affiliated to JNTUA, Ananthapuramu.

An ISO 14001:2004 & 9001: 2015 Certified Institution

Department of Computer Science & Engineering

Certificate Course on .Net Technology (04/03/2019 to 23/03/2019)

Schedule
S.No Date Time Faculty Topic
1 | 04/03/2019 | 4PM to 5PM Introduction about certification course
. Sri. S. Khaja Khizar
Mrs. V. Sudha
Mrs. B. Swetha
5PM to 6PM Mrs. B. Swetha Module I: Introduction to the .net initiative
and the .net platform:
e Detailed .NET Framework
architecture, Name spaces
2 | 05/03/2019 | 4PM to SPM Mrs. B. Swetha e Assemblies, Exploring Assemblies
and Namespaces
e Common Language
Implementation , Metadata and
Intermediate Language
5PM to 6PM | Mrs. B. Swetha e Garbage Collection, Versioning and
Side-by-Side Execution, The End to
DLL Hell, Managed Execution, COM
. Inter Op.
3 106/03/2019 | 4PM to SPM | Mrs. B. Swetha Installation procedure for .net technology.
5PM to 6PM | Mrs. B. Swetha Module II: Code Management
Data Types and Base Class Libraries -
Understanding .NET Data Types - Stream
and String Manipulation,
4 07/03/2019 | 4PM to 5SPM | Mrs. B. Swetha Files and 1/0, Collections - The Microsoft.
Visual Basic Namespace
5PM to 6PM | Mrs. B. Swetha Module III: Object Oriented Programming
Concepts:
Introduction to VB.NET and C#,
Namespaces
5 | 08/03/2019 | 4PM to SPM | Mrs. V. Sudha Creating Classes, Classes and Inheritance
5PM to 6PM | Mrs. V. Sudha Overloading




6 | 09/03/2019 | 4PM to SPM | Mrs. V. Sudha Constructors and Destructors
SPM to 6PM | Mrs. V. Sudha Inheritance
7 | 11/03/2019 | 4PM to SPM | Mrs. V. Sudha Controlling scope and visibility, Dispose
and Finalization, Modifiers, Properties and
Indexers
5PM to 6PM | Mrs. V. Sudha Attributes, Reflection API
8 | 12/03/2019 | 4PM to SPM | Mrs. V. Sudha Module IV:
Language Features Creating .NET
Projects, Namespaces,
5PM to 6PM | Mrs. V. Sudha Threads
9 |13/03/2019 | 4PM to SPM | Mrs. V. Sudha Debugging and Error Handling,
5PM to 6PM | Mrs. V. Sudha Structured Error Handling
10 | 14/03/2019 | 4PM to 5PM | Mrs. V. Sudha Module V:
User control: Creation of user control
5PM to 6PM | Mrs. V. Sudha Usage of user control
11 | 15/03/2019 | 4PM to 5PM | Mrs. B. Swetha Customer Control: Creation of customer
control
5PM to 6PM | Mrs. B. Swetha Usage of customer control
12 | 16/03/2019 | 4PM to SPM | Mrs. B. Swetha Gridview
5PM to 6PM | Mrs. B. Swetha Asp.net repeater control
13 | 18/03/2019 | 4PM to SPM | Mrs. B. Swetha File upload in asp.net
5PM to 6PM | Mrs. B. Swetha Asp.net security
14 | 19/03/2019 | 4PM to SPM | Mrs. B. Swetha Themes and master pages
5PM to 6PM | Mrs. B. Swetha App.config
15 |20/03/2019 | 4PM to SPM | Mrs. B. Swetha Global.asax
5PM to 6PM | Mrs. B. Swetha Module VI: web application using asp.net
16 |21/03/2019 | 4PM to 6PM | Mrs. B. Swetha web application using asp.net
17 | 22/03/2019 | 4PM to SPM | Mrs. B. Swetha Practical’s
5PM to 6PM | Mrs. B. Swetha Practical’s
18 |23/03/2019 | 4PM to 6PM | Sri. S. Khaja Khizar Exam, Certificate Distribution and Vote of
Mrs. V. Sudha Thanks
Mrs. B. Swetha
g,\dn\f\/ e
oordinator HoD
Dr. M. Sreenivasuly
M. E,+h D

Professer & HOO C5E
K.S.R.M. College of Fngincering
KADAPA-516003
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Department of Computer Science & Engineering

Certificate Course on .Net Technology from 04/03/2019 to 23/03/2019
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K.S.R.M. COLLEGE OF ENGINEERING

(UGC - Autonomous)
Kadapa, Andhra Pradesh, India— 516 003
Approved by AICTE, New Delhi & Affiliated to JNTUA, Ananthapuramu.

Certification course

net TECHNOLOGY
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Coordinator

Mr. S. Khaja Khizar @ 4Pm -6 Pm
Resource persons
Mrs. V. Sudha venue : MB 210

Mrs. B. Swetha




K.S.R.M. COLLEGE OF ENGINEERING
(AUTONOMOUS)
Pulivendala Road, Kadapa-516 005
Andhra Pradesh, India
Approved by AICTE, New Delhi & Affiliated to JNTUA, Ananthapuramu.
An ISO 14001:2004 & 9001: 2015 Certified Institution

ACTIVITY REPORT

Certification Course

On
.Net Technology
04/03/2019 to 23/03/2019
Target Group 3 B.Tech VI and VIII Semester Students
Details of Participants : 53 Students
Coordinator - Mr. S. Khaja Khizar
Asst. Prof, Dept. of CSE, KSRMCE
Organizing Department : Computer Science & Engineering
Venue : Web Technologies Lab (MB 210)

Description: Certification course on “.Net Technology” was organized by Dept. of CSE from
04/03/2019 to 23/03/2019. Mr. S. Khaja Khizar acted as Course Coordinator and Mrs. V.Sudha
and Mrs. B. Swetha acted as Resource Persons. The course is designed to provide complete
knowledge of .Net Technology and to enhance the programming skills of the students by giving
practical assignments to be done in labs. Thirty Two hours course was successfully completed
and participation certificates were provided to the participants.



Event Photos:

K.S.R.M Admmlstration Bu:tdmg, KSRM Hostel Rd, Andhra Pradesh 516003 !nd:a

Latitude 14.477354° Longztude 78.766248°
LOCAL 16:50:12 GMT 04:50:12 MONDAY 04.03.2019 ALTITUDE 30 METER

Resource person give brief overview about .Net Technology

K.S.R.M ini ion Building, KSR ' stel Rd, Andhra Pradesh 516003, India
' _ fe | ; gitude 78.766248°
LOCAL 16:50:12 GM v 24.03.2019 ALTITUDE 30 METER

Students participated in practical session




K.S.R.M Administration Building, KSRM Hostel Rd, Andhra Pradesh 516003, India
Latitude 14.477354°  Longitude 78.766248°

LOCAL 16:53:42 GMT 04:53:42 SATURDAY 23.03.2019 7 LTITUDE 30 METER 'f
Certificate Distribution
oordinator HoD

Dr. M. Sreenivasula,
M. E
Professer & HOO (C

fh. B,
E
K.S.R.M. College of Engineering
KADAPA-516003
®
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K.S.R.M. COLLEGE OF ENGINEERING‘

(UGC -~ Autonomous)
Kadapa, Andhra Pradesh, India~ 516 003
Approved by AICTE, New Delhi & Affiliated to INTUA, Ananthapuramu.

DEPARTMENT OF COMPUTER SCIENCE & ENGINEERING
CERTIFICATE OF PARTICIPATION

This is to certify that Mr/Miss. 2. Uma Devt
bearing Roll Number._159viAn5ia participated in a
certification course on ".Net Technology" organized by
department of Computer Science and Engineering from
04-03-2019 to 23-03-2019.

| fledeitin V.S s, Ml

e

COORDINATOR HOD PRINCIPAL
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K.S.R.M. COLLEGE OF ENGINEERING

(UGC -~ Autonomous)
Kadapa, Andhra Pradesh, India- 516 003
Approved by AICTE, New Dethi & Affiliated to INTUA, Ananthapuramu.

DEPARTMENT OF COMPUTER SCIENCE & ENGINEERING
CERTIFICATE OF PARTICIPATION

This is to certify that Mr/Miss. _ € - Haxtlcnidhna
bearing Roll Number._159y/An5e.2. participated in a
certification course on ".Net Technology" organized by

department of Computer Science and Engineering from
04-03-2019 to 23-03-2019.

e i A e

e
)

COORDINATOR HOD PRINCIPAL
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K.S.R.M. COLLEGE OF ENGINEERING

(UGC ~ Autonomous)
Kadapa, Andhra Pradesh, India~ 516 003
Approved by AICTE, New Delhi & Affiliated to INTUA, Ananthapuramu.

DEPARTMENT OF COMPUTER SCIENCE & ENGINEERING
CERTIFICATE OF PARTICIPATION

This is to certify that Mr/Miss. K, Ravik.umam
bearing Roll Number._159y/An%LQ participated In a
certification course on ".Net Technology" organized by

department of Computer Science and Engineering from
04-03-2019 to 23-03-2019.

COORDINATOR HOD PRINCIPAL




K.S.RM. COLLEGE OF ENGINEERING
UGC - AUTONOMOUS
Approved by AICTE, New Delhi & Affiliated to JNTUA, Ananthapuramu.

Kadapa, Andhra Pradesh, India— 516 003

FEEDBACK FORM

Certificate Course on “.Net Technology”, from 04-03-2019 to 23-03-2019

Organized

by

Department of Computer Science & Engineering

NAME:
Roll No:
S.No Feedback Item Excellent | Very Good Average Below
Good Average
1 Organization of
certificate course and
session planning by
resource person.
2 Clarity in content
delivery.
3 Content is relevant and
useful.
4 Adequate opportunity

to interact with
resource person.

Judicious mix of
concepts, principles
and practices.

Assignments and tasks
are interesting and
challenging.

Any suggestions for improvement.

Signature




K.S.RM. COLLEGE OF ENGINEERING
UGC - AUTONOMOUS
Approved by AICTE, New Delhi & Affiliated to JNTUA, Ananthapuramu.

Kadapa, Andhra Pradesh, India— 516 003

FEEDBACK FORM

Certificate Course on “.Net Technology”, from 04-03-2019 to 23-03-2019

Organized
by

Department of Computer Science & Engineering

NAME: [S9Y/Aoso| | A-Creefconth
Roll No: (S9v, AvTo)

S.No

Feedback Item

Excellent

Very
Good

Good

Below
Average

Average

1

Organization of
certificate course and
session planning by
resource person.

Clarity in content
delivery.

Content is relevant and

useful.

Adequate opportunity
to interact with
resource person.

Judicious mix of
concepts, principles
and practices.

<L

Assignments and tasks
are interesting and
challenging.

<
™

Any suggestions for improvement.

Qvee

Signature
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2.1 Introduction to .NET Technology

Introduction to .NET

.

Content :

— Introduction to .NET Technology

— Introduction to Web Based Applications
— Introduction to ASP.NET

.NET Framework Objectives

The .NET Framework is designed to fulfill the following
objectives:

—Provide object-oriented

—Provide environment for developing various types of
icati such as Wind based ications and Web-
based applications

—To ensure that code based on the .NET Framework can
integrate with any other code

Common Language Specification

CLS performs the following functions:

« Establishes a framework that helps enable cross-language
integration, type safety, and high performance code
execution

« Provides an object-oriented model that supports the
complete i ion of many i

« Defines rules that languages must follow, which helps
ensure that objects written in different languages can
interact with each other

Introduction to .NET Technology

.NET Framework

ce+ || c# || Jscript|| .

| Common Language Specification

L

‘ Windows |
ASP.NET Forms ‘ t ADO.NET

Base Class Library I

l (CLR) Common Language Runtime l

Operating System
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.NET Framework Base Class Library

 The Class Library is a comprehensive, object-oriented collection
of reusable types

These class library can be used to develop applications that
include:
~ Traditional command-line applications
— Graphical user interface (GUI) applications
- based on the latest i ided by ASP.NET
« Web Forms
* XML Web services
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What is .NET ?

Microsoft.NET is a Framework

— Microsoft .NET is a Framework which provides a common
platform to Execute or, Run the applications developed in
various programming languages.

— Microsoft announced the .NET initiative in July 2000.

— The main intention was to bridge the gap in
interoperability between services of various
programming languages.

* The .NET Framework consists of:

—The Common Language Specification (CLS)
It contains guidelines, that language should follow so that they
can icate with other .NET Itisalso
responsible for Type matching.

—The Framework Base Class Libraries (BCL)
A consistent, object-oriented library of
functionality and Applications.

—The Common Language Runtime (CLR)
A languag | & execution
that provides common runtime for application execution .

Common Language Runtime (CLR)

* CLR ensures:
— A common runtime environment for all .NET languages
—Uses Common Type System (strict-type & code-verification)
—Memory allocation and garbage collection
—Intermediate Language (IL) to native code compiler. Which
Compiles MSIL code into native executable code
—Security and interoperability of the code with other
languages
Over 36 languages supported today
— C#, VB, Jscript, Visual C++ from Microsoft

~ Perl, Python, Smalltalk, Cobol, Haskell, Mercury, Eiffel, Oberon, Oz, Pascal, APL,
CAML, Scheme, etc
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Execution in CLR

ot vel &)
Compiler] [Compiler] Compiler

Managed ___ sembly
code

Common Language RI#II“mE
JIT Compiler |

Native Code

[ Operating System Services

C# Features

Simple

Modern
Object-Oriented
Type-safe
Versionable
Compatible

Secure

How Are Static Web Pages Served ?

Visual Studio 2008 IDE

Microsoft has introduced Visual Studio.NET,
which is a tool (also called Integrated Development

i ) for developing .NET licati by
using programming languages such as VB, C#,
VC++ and VJ#. etc.

Introduction to Web Based
Applications

Dynamic web page

Dynamic Web sites provide its visitors to modify the content of
the web page based on their input.

They utilize databases and other mechanisms that enable to

— identify their visitors

— present them with customized greeting messages

— restructure the content according to user input etc..
+ Examples:

~ Online shopping stores,

— search engines

- email e - -

~ chat, community portals etc.

C# (C Sharp)

Microsoft C# (pronounced C Sharp) developed by Microsoft
Corporation, USA

New programming language that runs on the .NET Framework
C# is simple, modern, type safe, and object oriented
C# code is compiled as managed code

Combines the best features of Visual Basic, C++ and Java

Introducing Web Applications

Static web page

This type of web page consists of
HTML code typed directly into text
or a web page editor

Itis saved as an .htmor html
file

The content (text, images, hyperlinks, and so on) and
appearance of a static web page is always the same.

These web pages do not utilize any database or any
other technology that dynamically builds up pages or
content at runtime based on their visitors input

Dynamic web page
+ Dynamic Web sites make use of “server-side
technology” .
Server-side technologies add an extra layer to the
static web page that enablesthe Web Serverto
generate HTML on the fly.
The web server will first
—interpret the server-side code present in web
pages,
—generate the appropriate HTML and then

—send the response to the web browser.
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How Are Dynamic Web Pages Served?

3. Web Server collects the contents
(code + HTML) of the web page
WEB SERVER! and parses the contents to
produce HDML.
2. The Web Server

searches for the

requested page 4. The HTML stream is

sent back to the
requesting browser

. Browser processes
KDL and displays

1. The Web browser
sends a request

Introduction to ASP.NET

@ Itis built on .NET Common Language Runtime

® ASP.NET :
® Provides better user authentication
® Has better language support.
© Has a large set of new controls (web controls)
© Uses compiled code, which increases the performance of the

applications

® It is programmable using any of the .NET languages
(VB.NET, C#, VJ# etc).

® The ASP.NET pages are saved with the .aspx
extension.

Advantages of ASP.NET

Easy Programming Model
Flexible Language Options
Compiled Execution

Rich Output Caching
Web-Farm Session State
Enhanced Reliability
Master Pages

Themes

* Improved Security

* Web Services

Improved Performance and Scalability

Introduction to ASP.NET

ASPnet

Working of an ASP.NET Application

To execute an ASPNET file, the
following steps are followed:

. Aweb browser sends a
request for an ASPNET file to
the web server by using a
URL.

L

The web server receives the
request and retrieves the
appropriate ASP.NET file from
the disk or memory.

w

The web server forwards the
file to the ASP.NET script
engine for processing.

Visual Studio 2008 IDE

Introduction to ASP.NET

© ASP.NET is part of the Microsoft .NET framework
® ASP.NET is an effective and flexible technology for
creating interactive and dynamic web
pages.
e It is a convergence of two major Microsoft technologies:
—Active Server Pages (ASP)
* Active Server Pages is Microsoft’s server side scripting
technology for building dynamic web pages
— .NET Framework

* The .NET Framework is a suite of technologies designed by
Microsoft where program development takes place.

Working of an ASP.NET Application

ASP.NET |

the file from top to bottom and
executes it. G

4. The ASP.NET script engine reads n

Script
Engine

5. The processed ASP.NET file is b
~generated as an HTML B
document and the ASP.NET
script engine sends the HTML
page to the Web server.

6. The Web server then sends the
HTML code to the client which

interprets the output and CLIENT
displays it.

Creating a New Web Application

+ To start a new Web Application in VS 2008, Click the Create Web Site
button on the Start page or Select File > New > Web Site

s
+ The New Web Stte allows @2

you to choose: ((
sxp

« Templates

« Language for creating an
application =

+ Location where the application
will be created
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Creating a New Application
(Continued)

+ After you create a new Web Application, Default aspx page is added 1o this.
Webste. To Rename this page, Select the page from the Website node in the
Solution Explorer > Right Click > Rename,

o s Xt

* Files can be added to the Project,
using Solution Explorer:

« Right click on the project node, in
the Solution Explorer, and select
the option Add New ftem.

« The Add New ftem vindow vl
popup.

* Select the type o file (item)to be
‘added and click on Add. =

Toolbox

= To add controls in the Design Window use
Toolbox.

* There are various fool tabs available in the
Toolbox.

- The controls in the IDE are presented in a
hierarchicalmanner (e.g., Standard Tab, Data Tab,
Validation, Navigation, WebParts etc.).

- Depending on the type of project (application) the

toolbox tabs will vary.
* To view the tool box: el
~ Select menu View> Toolbox o

OR o

Project Setting

+ Project Settings can be adjusted using
various options in the Project
Properties menu of by using the
Solution Explorer window.

- These settings change based on the
developed.

Skt B,

type of appiication

« Setting Startup Page:

~ Right Clickon the form you want set as
the startup page in the Solution Explorer.

~ Select option Set As Start Page.

Startup Project (In case of muttiple
projects):

« Presents a tree view structure of files
present in the project.
- By default a New Website will contain:
« An App_Data folder
+ ADefault aspx page (including
Default aspx.cs)

To view Solution Explorer:

= Select View > Solution Explorer
OR

* Press buttons Ctri+W.S

To view or change the properties and events of a selected control during
design use the Properties Window
+ To configure a control:
~ Click once to select it

- Pross F4 or Select menu View > Properties
window

~ Modiy the appropriate properties in the window
There are various options provided for viewing
the properties of the selected control, such as:

- Press buttons ClrisAlt+Xor Clri+W, X ::::—m :
* You can also view the controls as icons by right- | = :&gﬁ:;:ﬂmﬁmﬂgmﬂmp i
slec:&o:gu;exo::\::u vant to change and ~ Select Option Set As StartUp Project S
5
Solution Explorer : :
p Properties Window Resources

* Visual Studio 2008 Website
http://msdn.microsoft.com/vstudio,

Solution Explorer (Continued)

* The Toolbar at the top of Solution Explorer enables various tasks.

Code
Refresh CopyWebsite

Adding an Event
Events can be added to = ir s e e
the code in one of three
ways:
1. Double clicking a controlin
design view
2. Typingthe code manually
3.Selecting the Events Icon
and double cicking the
required event from the
Properties Window

Questions and Comments




